Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел. нужно к этой задачке составить блок-схему. пожалуйста. дам 60 баллов
Ответы на вопрос
Ответил Osleeenok
0
var i:integer;
sum,sr,n:real;
begin
sum:=0;
for i:=1 to 10 do
begin
read(n);
sum:=sum+n;
end;
sr:=sum/10;
write('sum=', sum, 'sred=', sr);
end.
sum,sr,n:real;
begin
sum:=0;
for i:=1 to 10 do
begin
read(n);
sum:=sum+n;
end;
sr:=sum/10;
write('sum=', sum, 'sred=', sr);
end.
Приложения:

Ответил rvbn
0
спасибо огромное
Ответил NotOfNoumber
0
var
i:integer;
a,sum,s:real;
begin
for i:=1 to 10 do
begin
read(a);
sum:=sum+a;
end;
write('Сумма: ',sum);
s:=s/10;
write('Cреднее арифметическое: ',s);
end.
i:integer;
a,sum,s:real;
begin
for i:=1 to 10 do
begin
read(a);
sum:=sum+a;
end;
write('Сумма: ',sum);
s:=s/10;
write('Cреднее арифметическое: ',s);
end.
Приложения:

Ответил rvbn
0
спасибо
Новые вопросы
Физика,
2 года назад
Литература,
2 года назад
Математика,
9 лет назад
Геометрия,
9 лет назад
Алгебра,
10 лет назад