Информатика, вопрос задал dimon4325 , 10 лет назад

Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива

Ответы на вопрос

Ответил 4MD
0

Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.

var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max :=  a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max :=  a [ i ];
writeln (max + a [ 1 ])
end.

Ответил Sky09
0

uses crt;

var
  a:array [1..1000] of integer;
  max,i,k:integer;
begin
  write('Введи количество элементов массива: '); read(k);
  for i:=1 to k do
  begin
    a[i]:=random(100)-50;
    write(a[i]:4);
  end;

  writeln;
  max:= a[1];
  for i:=1 to k do
    if a[i]>max then max:=a[i];
  writeln('Максимальный элемент: ',max);
  writeln ('Сумма первого и максимального элементов: ',max+a[1])
end.

Новые вопросы