Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим числом. Вывести массив и кол-во замен.
(в Pascal)
Ответы на вопрос
Ответил hello93
0
const
n=10;
var
a : array [1..n] of integer;
i,k,m : integer;
begin
randomize;
k:=0;
writeln('введите число, на которое заменять элементы: ');
read(m);
writeln('Массив:');
for i:=1 to n do
begin
a[i]:=random(10)+1;
write(a[i]:4);
end;
writeln;
for i:=1 to n do
if (a[i]>7) then
a[i]:=m;
writeln('изменённый массив:');
for i:=1 to n do
write(a[i]:4);
end.
Ответил ClarisVerbis
0
аа, точно. спасибо!
Ответил ClarisVerbis
0
извините еще за беспокойство. а в другой задаче можно обойтись без const в решении?
Ответил hello93
0
да, просто, когда объявляешь массив написать не от 1 до n, а например, от 1 до 5
Ответил ClarisVerbis
0
https://znanija.com/task/31971701
Ответил ClarisVerbis
0
https://znanija.com/task/31973054
Новые вопросы