Написать программу, которая вводит целые случайные числа в диапазоне от -10 до 10 с помощью оператора random, затем выводит весь массив на экран и после этого выводит на экран количество чисел больших среднего арифметического. Программу нужно написать в паскале
fsdfsd1974:
Через одномерный массив?
Ответы на вопрос
Ответил fsdfsd1974
1
Среднее арифметическое по условию не выводит.
program v1;
var a:array[0..30]of integer;
i,n,sum:integer;
t:real;
begin
sum:=0;
writeln('Введите размерность матрицы: '); readln(n);
randomize;
for i:=1 to n do a[i]:=random(20)-10;
write('Значение матрицы: ');
for i:=1 to n do write(a[i]:5); writeln;
for i:=1 to n do begin
sum:=sum+a[i];
t:= sum/n ;
end;
for i:=1 to N do if a[i]>t then write(a[i]:3);
writeln;
end.
Приложения:

Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
8 лет назад
Алгебра,
8 лет назад