Написать программу, которая вставляет число K в заданную
возрастающую последовательность таким образом, что в результате полученная
последовательность также остается полностью возрастающей.
(Язык программирования - Паскаль) - Писать адекватно
Ответы на вопрос
Ответил PopCop312
0
var a:array[1..11] of integer;
i,k,t:integer;
begin
for i:=1 to 10 do
read(a[i]);
read(k);
for t:=1 to 11 do
if a[t]>k then break;
for i:=11 downto t+1 do
a[i]:=a[i-1];
a[t]:=k;
for i:=1 to 11 do
write(a[i],' ');
end.
i,k,t:integer;
begin
for i:=1 to 10 do
read(a[i]);
read(k);
for t:=1 to 11 do
if a[t]>k then break;
for i:=11 downto t+1 do
a[i]:=a[i-1];
a[t]:=k;
for i:=1 to 11 do
write(a[i],' ');
end.
Новые вопросы