Информатика, вопрос задал guten77 , 2 года назад

Написать программу , которая в последовательности n-чисел, вычисляет сумму нечётных.​ Помогите, очень срочно нужно. (Паскаль)


KnowsUser1: Язык?
guten77: это информатика
guten77: язык Паскаль
KnowsUser1: для n есть какие то рамки?
guten77: нет

Ответы на вопрос

Ответил defendercryak
2

program test;

var a:array[1..10000000]of integer;

   i,s,n:integer;

begin

writeln ('Сколько чисел в последовательности?');

read(n);

writeln('Сформированная последовательность:');

for i:=1 to n do begin

a[i]:=random(500);

write (a[i]:4);

end;

writeln;

for i:=1 to n do

if i mod 2=0 then s:=s+a[i];

write ('Сумма четных= ',s);

end.

Новые вопросы