Написать программу которая создает одномерный массив из n случайных эллементов (др1000) и выводит на экран
1. Сам массив
2. Кол-во нечет чисел
3. Наим. Эллемент Массива
4 ср. Ариф. Членов массива
Ответы на вопрос
Ответил Аноним
0
Писал в среде PascalABC:
var a:array of integer;
k,min,s,n,i:integer;
begin
write('Задайте размер массива = ');readln(n);
writeln;
setlength(a,n);
for i:=0 to n -1 do begin
a[i]:=random(101);
if a[i] mod 2 <> 0 then k:=k+1;
if (a[i] < min) or (i=0) then min:=a[i];
s:=s+a[i];
end;
writeln('Массив:');
writeln(a);
writeln('Кол-во нечетных элементов = ',k);
writeln('Минимум = ',min);
writeln('Среднее ариф. = ',s/n);
end.
var a:array of integer;
k,min,s,n,i:integer;
begin
write('Задайте размер массива = ');readln(n);
writeln;
setlength(a,n);
for i:=0 to n -1 do begin
a[i]:=random(101);
if a[i] mod 2 <> 0 then k:=k+1;
if (a[i] < min) or (i=0) then min:=a[i];
s:=s+a[i];
end;
writeln('Массив:');
writeln(a);
writeln('Кол-во нечетных элементов = ',k);
writeln('Минимум = ',min);
writeln('Среднее ариф. = ',s/n);
end.
Новые вопросы