Информатика, вопрос задал Mixa284 , 7 лет назад

Написать программу, которая создает и заполняет массив из 10 элементов случайными целыми числами в диапазоне от 10 до 99.
Упорядочить массив по возрастанию последней цифры числа. вывести массив
Очень срочно! Язык Паскаль.

Ответы на вопрос

Ответил restIess
1

var a : array [1..10] of integer;

i, j, temp : integer;

begin

randomize;

write('Сгенерированный массив: ');

for i := 1 to 10 do

   begin

       a[i] := random(90) + 10;

       write(a[i], ' ');

   end;

for i := 1 to 10 do

   for j := 1 to 9 do

       begin

       if (a[j] mod 10) > (a[j+1] mod 10) then

           begin

           temp := a[j];

           a[j] := a[j+1];

           a[j+1] := temp;

           end;

       end;

writeln;

write('Отсортированный массив: ');

for i := 1 to 10 do

   write(a[i], ' ');

end.

Ответил vimmortal2
1

Ответ:

var

 arr: array[1..10] of integer;

 i, k, j: integer;

begin

 randomize;

 writeln('Массив: ');

 for i := 1 to 10 do arr[i] := random(10,99);

 for i := 1 to 10 do

   for k := 1 to 9 do

     if (arr[k] mod 10) > (arr[k + 1] mod 10) then begin

       j := arr[k];

       arr[k] := arr[k + 1];

       arr[k + 1] := j;

     end;

 for i := 1 to 10 do write(arr[i],' ');

end.

Новые вопросы