Информатика, вопрос задал tolubicki46 , 2 года назад

Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит максимальный элемент и выведет его на экран.

Ответы на вопрос

Ответил asphyxik
0

Ответ:

сначала надо отсортировать массив.

я отсортировал по убыванию и вывел первый элемент, т.е максимальный

Объяснение:

const

m = 10;

var a: array[1..m] of integer;

i,j:integer;

begin

for i:=1 to m do begin

  read(a[i]);

end;

for i:=1 to m-1 do

  for j:=1 to m-i  do

    if a[j] < a[j+1] then begin

      swap(a[j],a[j+1]);

    end;

    writeln;

 for i:=1 to m do

   write(a[i],' ');

   writeln;

   writeln(a[1]);

end.

Ответил LRSM
0

PascalABC.NET

Кратчайшее решение:

  • ### RAI(10).Max.Pr

Другое из множества возможных решений:

  • ##
  • var a := ReadArrInteger(10);
  • var max := a.Max;
  • Print('Максимальный элемент:', max)
Приложения:
Новые вопросы