написать программу, которая считает, сколько слов в тексте, введенном с клавиатуры
Приложения:

Ответы на вопрос
Ответил pro100LiNa
1
const Alpha : set of char=['A'..'Z','А'..'П','Р'..'Я','a'..'z','а'..'п','р'..'я'];
var s:string;
i:integer;
wc:integer;
begin
writeln('Введите текст'); readln(s);
i:=1; wc:=0;
Repeat
while NOT(s[i] in Alpha) and (i<=length(s)) do inc(i);
if (i<=length(s)) then inc(wc);
while (s[i] in Alpha) and (i<=length(s)) do inc(i);
Until (i>length(s));
writeln('Количество слов в этом тексте = ',wc);
end.
Новые вопросы
Українська мова,
2 года назад
Русский язык,
2 года назад
Геометрия,
2 года назад
Другие предметы,
2 года назад
Математика,
8 лет назад