Информатика, вопрос задал Herfindale , 9 лет назад

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.
Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

Ответы на вопрос

Ответил ussrex
0
program Cikle;
uses crt;
var a,b,i,k:integer;
Begin
clrscr;

write('Введите А: '); readln(a);
write('Введите B: '); readln(b);
if a>b then begin i:=a; a:=b; b:=i end;
{_______________________________________}
{1 способ реализации - цикл for}
k:=0;
for i:=a to и do k:=k+i;
{_______________________________________}
{2 способ реализации - цикл с предусловием while}
k:=0;
while a<=b do begin
k:=k+a;
a:=a+1 end;
{_______________________________________}
{3 способ - цикл с постусловием repeat}
k:=0;
repeat
k:=k+a;
a:=a+1;
until a>b;
{_______________________________________}
{Окончание программы одинаковое для всех способов}
Writeln('Сумма элементов в интервале [A;B] равна ', k)
readln
End.


Новые вопросы