Написать программу, которая решает уравнение ax+b <0 относительно x для любых чисел a и b , введёных с клавиатуры.
Помогите пожалуйста)
Ответы на вопрос
Ответил 4MD
0
ax + b < 0
ax < -b
x < - b / a
a, b могут быть дробными числами.
Язык программирования: Паскаль
var
a, b : real;
begin
readln (a);
readln (b);
if a <> 0 then
writeln ('x < ', - b / a);
if (a = 0) and (b < 0) then
writeln ('x - любое число');
if (a = 0) and (b >= 0) then
writeln ('нет решений')
end.
Ответил Mishka28
0
var
a,b,x:real;
begin
write ('A = ');readln(a);
write ('B = ');readln(b);
if (a=0) and (b>=0) then writeln ('Нет решений') else
if (a=0) and (b<0) then writeln ('X - любое число') else
if a>0 then writeln ('X < ',-b/a:0:4) else
if a<0 then write ('X > ',-b/a:0:4);
readln;
end.
Новые вопросы
Информатика,
6 лет назад
Математика,
6 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад
Физика,
10 лет назад