Информатика, вопрос задал ksyugavrilova03 , 2 года назад

Написать программу которая рассчитывает 10!
Использовать цикл с параметром ( счётчиком) и цикл с предусловием.
Большое спасибо

Ответы на вопрос

Ответил moboqe
1

Ответ:

Program fact10;

var

i:byte;

fact:longint;

begin

writeln('Цикл с параметром');

fact:=1;

for i:=2 to 10 do

fact:=fact*i;

writeln('10! = ',fact);

writeln('Цикл с предусловием');

fact:=1;

while (i<>1) do

begin

fact:=fact*i;

i:=i-1;

end;

writeln('10! = ',fact);

end.

Новые вопросы