Информатика, вопрос задал filya67 , 10 лет назад

Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр.

Ответы на вопрос

Ответил sansanic
0

var a,a1,a2,a3 : integer;  

begin

  readln(a);

  a1:=a div 100;

  a2:=(a mod 100) div 10;

  a3:=(a mod 100) mod 10;

  writeln(a1+a2+a3);

end.

 а - само число, а1-число сотен, а2-число десятков, а3-число единиц

 

Новые вопросы