Информатика, вопрос задал metroada2008 , 6 лет назад

Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получает на вход число. Необходимо посчитать сколько раз это число встречается в массиве.​


nazikmuz: Тоесть пользователь должен ввести 10 элементов массива?
metroada2008: Да
metroada2008: просто написал как учитель в дз
nazikmuz: Понял,сейчас кидаю код
metroada2008: и ещё он на паскале
metroada2008: я забыл написать
nazikmuz: Код на С++ вам над,зная синтаксис паскаля переделать не составит проблем,языки работают на одинаковом принципе
nazikmuz: дан*

Ответы на вопрос

Ответил timakk
1

......................

Приложения:
Ответил nazikmuz
1

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


nazikmuz: Использовал при задаче функции,можно конечно обойтись и без них,но принято писать так
Новые вопросы