Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. Размер последовательности определяет сам пользователь программы. Принять, что последовательность состоит только из целых положительных чисел.
Ответы на вопрос
Ответил g0golmogol
0
program qq;
var a, b, c, d, e:integer;
BEGIN
d:=0;
e:=0;
writeln('Введите количество чисел');
readln (a);
writeln ('Введите числа');
for b:=1 to a do
begin
readln (c);
if c mod 8 = 0 then
d:=d+c;
e:=e+1;
end;
Writeln ('Количество чисел кратных восьми - ', e, '; Их сумма - ', d);
END.
var a, b, c, d, e:integer;
BEGIN
d:=0;
e:=0;
writeln('Введите количество чисел');
readln (a);
writeln ('Введите числа');
for b:=1 to a do
begin
readln (c);
if c mod 8 = 0 then
d:=d+c;
e:=e+1;
end;
Writeln ('Количество чисел кратных восьми - ', e, '; Их сумма - ', d);
END.
Ответил g0golmogol
0
хотя нельзя
Ответил AnonimusPro
0
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
write('кол-во чисел, делящихся на 8 без остатка: ',a.Count(),'; сумма: ',a.Sum());
end.
//Версия 3.3, сборка 1627
begin
var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
write('кол-во чисел, делящихся на 8 без остатка: ',a.Count(),'; сумма: ',a.Sum());
end.
Новые вопросы
Информатика,
2 года назад
География,
2 года назад
Физика,
8 лет назад
История,
9 лет назад
Математика,
9 лет назад