Информатика, вопрос задал tskhovrebov2004 , 8 лет назад

Написать программу, которая переводит из двоичной в десятичную систему счисления на С# или С.

Ответы на вопрос

Ответил petyaGavrikov
0
using System;

public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i<s.Length; i++){
   if (s[i]=='1') n += d;
   d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}

Пример:
Введите двоичное число: 1110111
n = 119
Новые вопросы