. Написать программу, которая определяет вид треугольника (прямоугольный, остроугольный, тупоугольный) по введенный с клавиатуры длинам сторон треугольника, либо выдать сообщение «Треугольника с введенными сторонами не существует!».
Ответы на вопрос
type
tr = record
a,b,c:real;
end;
var
i:integer;
s:real;
x: tr;
procedure vvod(var n:tr);
var
flagtr:boolean;
begin
write('Введите стороны треугольника: ');
repeat
readln(n.a,n.b,n.c);
if (n.a+n.b<n.c) or (n.b+n.c<n.a) or (n.a+n.c<n.b)
or (n.a<0) or (n.b<0) or (n.c<0) then
begin
flagtr:=false;
write('Треугольник не может существовать. Повторите ввод: ');
end
else
flagtr:=true;
until flagtr=true;
end;
begin
repeat
writeln('1: Ввести треугольник');
writeln('2: Выход');
write('Выберите действие: '); readln(i);
case i of
1: begin
vvod(x);
with x do
begin
if (a>b) and (a>c) then
begin
s:=c;
c:=a;
a:=s;
end
else
if (b>a) and (b>c) then
begin
s:=c;
c:=b;
b:=s;
end;
if sqr(c)>(sqr(a)+sqr(b)) then
writeln('Это тупоугольный треугольник')
else
if sqr(c)<(sqr(a)+sqr(b)) then
writeln('Это остроугольный треугольник')
else
writeln('Это прямоугольный треугольник');
end;
writeln;
end;
2: i:=0;
end;
until i=0;
end.
Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!