Информатика, вопрос задал warframed981 , 1 год назад

Написать программу, которая определяет сколько единиц в числе, которое ввёл пользователь. Например, в числе 197313 – две единицы. ( циклом)

Ответы на вопрос

Ответил gfhjkmgfhjkm20
0

Ответ:

program p1;

var n,k1:integer;

begin

k1:=0;

write ('Введите число ');

readln (n);

write ('Количество единиц в числе ',n,' равно ');

repeat

if n mod 10 = 1 then k1:=k1+1;

n:=n div 10;

until n=0;

write(k1);

end.

Ответил psevdoedison
0

Ответ:

На python:

Объяснение:

a = input("Введите число: ")

b = 0

for i in list(a):

   if i == '1':

       b += 1

print("'1' - ", b)

Новые вопросы