Информатика, вопрос задал muratamraev , 9 лет назад

Написать программу которая определяет нуль и считает его количество из ряда введенных чисел. И объяснить каждую

Ответы на вопрос

Ответил Farixy
0
var s:string;   
i,sum:integer; // Объявление переменных
begin             // Начинаем программу
writeln('Vvedite chislo'); // Вывод текста
readln(s); // Ввод текста
sum:=0; // Присваиваем переменной sum значение 0 чтобы при вводе текста отличного от 0, программа выводила правильный результат то есть 0.
for i:=1 to length(s) do if s[i]='0' then sum:=sum+1; // Запускаем счетчик с 1 до length(s) что значит эта команда, она считает сколько в тексте символов. И проверяем с 1 символа до length(s) совпадает ли символ со значением 0, если совпадает то прибавляем 1.
writeln(sum); // Вывод суммы
end. // Конец программы
Новые вопросы