Информатика, вопрос задал Alexandrovna1996 , 10 лет назад

написать программу, которая определяет какой элемент максимальный или минимальный первым встречается в одномерном массиве из 10 чисел(паскаль)

Ответы на вопрос

Ответил Аленусик
0
consr n=10;
var a,i,max,min,k,p:integer;
m:array [1..n] of integer;
begin
for i:=1 to n do
begin
a:=random(21)-10;
m[i]:=a;
write (m[i],' ');
end;
max:=m[1];
min:=m[1];
k:=1;
p:=1;
for i:=1 to n do
begin
if m[i]>max then
  begin
  max:=m[i];
  p:=i;
  end;
if m[i]<min then
  begin
  min:=m[i];
  k:=i;
  end;
end;
if p>k then writeln ('минимальный раньше')
else writeln ('максимальный раньше');
end.
Ответил Sky09
0
Во вложении
--------------------
Приложения:
Новые вопросы