Информатика, вопрос задал Lolly1boo , 10 лет назад

Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N

Ответы на вопрос

Ответил Maori
0

program Sum;

var

    a,b,c,s: integer;

begin

WriteLn('Введите числа а,в,с');

ReadLn(a,b,c);

s:=a+b+c;

WriteLn('Сумма чисел равна',s);

end.

Ответил Tonoyankar
0

program Sum;

var

    a,s: integer;

begin

WriteLn('Введите трехзначное число а');

ReadLn(a);

While (a div 10>0)

begin

s:=s+ (a mod 10 );

a:=a div 10;

end

s:=s+a;

WriteLn('Сумма чисел равна',s);

end.

Новые вопросы