Написать программу, которая находит сумму четных чисел до ввода цифры 0.
Ответы на вопрос
Ответил GSTLB
0
#include <iostream>
#include <vector>
using namespace std;
void solve(){
int sum = 0;
while(true){
int x;
cin >> x;
if(x == 0)
break;
sum += (x % 2 == 0) * x;
}
cout << sum;
}
signed main(){
solve();
}
Ответил gfhjkmgfhjkm20
1
Ответ:
program z1;
var a,s:integer;
begin
a:=-1;
s:=0;
while a <> 0 do
begin
write('a = ');
readln(a);
if a mod 2 = 0 then s:=s+a
end;
write('s = ', s)
end.
Новые вопросы