Информатика, вопрос задал moyularu , 1 год назад

Написать программу , которая находит количество цифр в заданной строке

Ответы на вопрос

Ответил flash77779
1

def count_digits_in_string(s):

   return sum(character.isdigit() for character in s)

# Получаем строку от пользователя

user_string = input("Введите строку: ")

# Выводим количество цифр в строке

print("Количество цифр в заданной строке: ", count_digits_in_string(user_string))

В этой программе мы определяем функцию count_digits_in_string, которая использует генераторное выражение для подсчета количества символов, являющихся цифрами, в данной строке s. Затем мы получаем строку от пользователя и выводим количество цифр в этой строке.

Ответил p15
1

Ответ:

print("Количество цифр в заданной строке: ",sum(map(lambda c:c.isdigit(),input("Введите строку: "))))

Объяснение:

Одна строка!

Новые вопросы