Информатика, вопрос задал Alexpoll , 7 лет назад

Написать программу, которая находит число с максимальной суммой цифр на C++

---------------------------------------------------------------------------------------------

Пользователь вводит количество чисел (N). В программе, с помощью датчика случайных чисел, генерируются эти числа. Написать программу, которая находит число с максимальной суммой цифр.


VbogdanV: Расскажи подробнее про датчик случайных чисел, и тогда помогу тебе

Ответы на вопрос

Ответил restIess
1

#include <iostream>

#include <cmath>

#include <ctime>

int summr(int N) {

N = abs(N);

int _sum = 0;

while (N > 0) {

 _sum += N % 10;

 N /= 10;

}

return _sum;

}

signed main() {

srand(time(NULL));

setlocale(LC_ALL, "Rus");

int n, x, _maxSum, _numberMaxSum;

std::cin >> n;

_numberMaxSum = x = rand() % 100;

_maxSum = summr(x);

std::cout << x << " ";

for (int i = 1; i < n; i++) {

 x = rand() % 100;

 if (summr(x) > _maxSum) {

  _numberMaxSum = x;

  _maxSum = summr(x);

 }

 std::cout << x << " ";

}

 

std::cout << "\nЧисло с максимальной суммой цифр: " << _numberMaxSum;

return 0;

}

Новые вопросы