Информатика, вопрос задал hhjbvchhg5688 , 6 лет назад

Написать программу, которая ищет среднее арифметическое всех чисел последовательности

в паскале

Ответы на вопрос

Ответил sabirovaralina2011
0

Ответ:

Uses crt;

Const n=8;

Var

a: array[1..n] of integer;

i,count: byte;

sr_ar: integer;

Begin

ClrScr;

For i:=1 to n do

Begin

Write('a[',i,'] = ');

ReadLn(a[i]);

End;

ClrScr;

For i:=1 to n do write(a[i],' ');

WriteLn;

For i:=1 to n do

If a[i]<>0 then

Begin

inc(count);

inc(sr_ar,a[i]);

End;

sr_ar:=sr_ar div count;

WriteLn('среднее арифметическое ненулевых элементов: ',sr_ar);

ReadKey

End.

Объяснение:

вроде так


tolkuev: К чему такие сложности, зачем использовать массив и усложнять код до невозможности?
Новые вопросы