Информатика, вопрос задал vagidov99 , 9 лет назад

Написать программу которая для введённого пятизначного числа выводит количество нулей в нем

Ответы на вопрос

Ответил clinteastwood2
0
Вот уже писал.
uses crt;
var a,n,i:integer;
begin clrscr;
write('Vvedite chislo: ');
read(a); n:=0;
while a<>0 do begin
if a mod 10=0 then inc(n);
a:=a div 10;
end;
writeln('N=', n);
end.
Ответил A1dar
0
Зачем нужна переменная i ?
Ответил clinteastwood2
0
незачем.. Просто когда переделывал код, видимо не заметил, бывает
Ответил A1dar
0
var
   n: integer;
begin
  read(n);
  write(ord(n mod 10 = 0) + ord(n div 10 mod 10 = 0) + ord(n div 100 mod 10 = 0) + ord(n div 1000 mod 10 = 0));
end.
Новые вопросы