Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия:
а) Четные числа делит на 2 и результат выводит на экран
б) нечетные числа выводит на экран без изменений
Ответы на вопрос
Ответил PopCop312
0
var a,b,c:integer;
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.
Новые вопросы
Физика,
2 года назад
Английский язык,
2 года назад
Химия,
10 лет назад
История,
10 лет назад
История,
10 лет назад