Информатика, вопрос задал nastycat112 , 7 лет назад

Написать программу, которая будет вводить с клавиатуры положительные числа до тех пор, пока не будет введена -1. Все числа должны записываться в один список и в конце работы программы из списка должны быть распечатаны сначала четные, затем не четные.
На Python

Ответы на вопрос

Ответил ilyaand1
0
Не очень корректное решение, но выводит вроде бы правильно

total = []
n = int(input())
total.append(n)
while n >= 0:
   n = int(input())
   total.append(n)
del total[-1]
for k in total:
   if k % 2 == 0:
       print(k)
   else:
       print(k)

Ссылка на код: https://pastebin.com/cRTRMS3L
Ответил dDeVoChKa
0
Если Вам не сложно....Помогите мне тоже, пожалуйста...Я Вас ооочень прошу..( Вы последняя надежда...(( https://znanija.com/task/31576828
Ответил ilyaand1
0
Сорри, мы это еще не проходили
Ответил dDeVoChKa
0
Это 8 класс...:(
Ответил ilyaand1
0
Так я питон не в школе учу, в я лицее
Ответил dDeVoChKa
0
Ясно...Спасибо за готовность помочь....Но я сейчас заплачу наверное...Задания жестокие и никто помочь не может((
Новые вопросы