Написать программу к задаче: Дано число. Найти сумму и произведение его цифр.
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
var n,sum,p: integer;
begin
readln(n);
sum:=0;
p:=1;
while n<>0 do
begin
sum:=sum+n mod 10;
p:=p*(n mod 10);
n:= n div 10;
end;
writeln('сумма цифр: ',sum);
write('произведение: ',p);
end.
var n,sum,p: integer;
begin
readln(n);
sum:=0;
p:=1;
while n<>0 do
begin
sum:=sum+n mod 10;
p:=p*(n mod 10);
n:= n div 10;
end;
writeln('сумма цифр: ',sum);
write('произведение: ',p);
end.
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад