Информатика, вопрос задал XBOXLIFE , 10 лет назад

Написать программу из 2 частей. В основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. Подсчет факториалов реализовать в функции

Ответы на вопрос

Ответил kage1998
0
program gt;
var i,s,l:integer;
function IOI(a:integer):integer;
begin
if(a mod 2=1)then IOI:=1 else IOI:=0;
end;
begin
s:=1;
l:=1;
for i:=2 to 9 do
begin
if(IOI(i)=1)then begin
l:=l*i*(i-1);
s:=s+l;
end;
end;
writeln(s);
end.
Ответил XBOXLIFE
0
а как массив одномерный вписать в основной программе и с ним это все проделать?
Ответил mefody66
0
На Visual Basic с массивом
Sub Program
Dim A(10) As Integer, i As Integer, S As Long
S = 0
For i = 1 To 9 Step 2
A(i) = i
S = S + Fact(A(i))
Next i
Text1.Text = S
End Sub

Function Fact(n)
Dim i As Integer
Fact = 1
For i = 1 To n
Fact = Fact * i
Next i
End Function

Почему во всех институтах изучают Pascal, 
если программы на Basic короче и быстрее работают?
Ответил mefody66
0
Питон не знаю, а С++ - это вообще язык, ориентированный на создание ошибок
Новые вопросы