Написать программу. Имеется билет на автобус с 6-тизначным
номером. Определить, является ли билет счастливым. Нарисовать блок-схему. Язык: Паскаль
Ответы на вопрос
Ответил personanonim22
2
Ответ:
Программа:
var n,a1,a2,s1,s2:integer;
begin
write('n = '); readln(n);
a1:=n div 1000;
s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);
a2:=n mod 1000;
s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);
if s1=s2 then writeln('Билет счастливый')
else writeln('Билет не счастливый')
end.
Пример:
n = 123231
Билет счастливый
Объяснение:
Ответил blink32
0
Объяснение:
билет счастливый))))))))))
Новые вопросы
Математика,
2 года назад
Другие предметы,
2 года назад
Информатика,
7 лет назад
Алгебра,
8 лет назад