Написать программу и доказать её работоспособность.
Условие задачи:
Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.
Pascal ABC
Полное решение задачи, заранее спасибо)
Ответы на вопрос
Ответил wolf18000
0
program z8;
uses crt;
var a:array[1..259] of shortint;
i,k,n:byte;
s:integer;
begin
clrscr;
randomize;
write('Vvedi razmernost massiva=');
readln(n);
for i:=1 to n do begin
a[i]:=random(100--100+1)+-100;
write(a[i]:4);
if a[i]<0 then
s:=s+a[i];
if odd(a[i]) then
k:=k+1;
end;
writeln;
writeln('Сумма отрицательных элементов равна ',s);
writeln('Кол-во нечётных элементов равно ',k);
readkey
end.
uses crt;
var a:array[1..259] of shortint;
i,k,n:byte;
s:integer;
begin
clrscr;
randomize;
write('Vvedi razmernost massiva=');
readln(n);
for i:=1 to n do begin
a[i]:=random(100--100+1)+-100;
write(a[i]:4);
if a[i]<0 then
s:=s+a[i];
if odd(a[i]) then
k:=k+1;
end;
writeln;
writeln('Сумма отрицательных элементов равна ',s);
writeln('Кол-во нечётных элементов равно ',k);
readkey
end.
Новые вопросы
Математика,
2 года назад
Информатика,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Алгебра,
10 лет назад