Информатика, вопрос задал natashamironov2 , 8 лет назад

Написать программу для вычисления следующего выражения: s=Под корнем |х|+|y| +3(без корня) .Ооочень срочно надо.

Ответы на вопрос

Ответил petyaGavrikov
0

Программа на паскале:

var x,y,s:real;

begin

writeln('Введите x и y:');

readln(x,y);

s:=sqrt(abs(x)+abs(y))+3;

writeln('s = ',s:6:4);

end.

Пример:

Введите x и y:

-5.1 2.7

s =  5.7928

Ответил natashamironov2
0
А откуда вы взяли 6 и 4?
Ответил petyaGavrikov
0
Из головы ). :6:4 - формат вывода вещественных значений. 6 позиций отводится для вывода всего числа, 4 позиции - для вывода дробной части. Можете другие значения написать вместо 6 и 4.
Новые вопросы