Написать программу для ввода 10 чисел с клавиатуры,не превышающих 1000 и кратных 5. Найти сумму этих чисел. Срочнооо нада!!!!!!!!!!!!!!!!!!
Ответы на вопрос
Ответил Аноним
0
var
i,x,s:integer;
f:boolean;
begin
for i:=1 to 10 do
begin
f:=false;
repeat
writeln('Введите число:');
readln(x);
if (x<=1000) and (x mod 5=0) then
begin
s:=s+x;
f:=true;
end
else writeln('Число не удовлетворяет требованиям.');
until f;
end;
writeln('Сумма равна : ',s);
end.
i,x,s:integer;
f:boolean;
begin
for i:=1 to 10 do
begin
f:=false;
repeat
writeln('Введите число:');
readln(x);
if (x<=1000) and (x mod 5=0) then
begin
s:=s+x;
f:=true;
end
else writeln('Число не удовлетворяет требованиям.');
until f;
end;
writeln('Сумма равна : ',s);
end.
Ответил JlaIIa
0
var a,b: integer;var M: array[1..10] of integer;begina:=1;while a<>1000 do beginreadln(a);b:=b+1;if a mod 10 = 5 then M[b]:=a;end;writeln(M[1]+M[2]+M[3]+M[4]+M[5]+M[6]+M[7]+M[8]+M[9]+M[10]);end.
Ответил Аноним
0
Программа дает неверный результат
Новые вопросы
Немецкий язык,
2 года назад
Английский язык,
2 года назад
Обществознание,
9 лет назад
Литература,
10 лет назад