Информатика, вопрос задал vishnya39 , 10 лет назад

Написать программу для сложения А и В в троичной системе счисления.
Числа А и В  хранятся в первой строке входного файла Exemp.in их сумма в троичной системе-в выходном файле Exemp5.out

Ответы на вопрос

Ответил kage1998
0
program chik;
var a,b,q,s1,s2,s:longint;
begin
read(a,b);
s1:=0;
while a>0 do
begin
q:=a mod 3;
a:=a div 3;
s1:=s1*10+q;
end;
s2:=0;
 while b>0 do
begin
q:=b mod 3;
b:=b div 3;
s2:=s2*10+q;
end;
s:=s1+s2;
writeln(s);
end.
Новые вопросы