Информатика, вопрос задал barabanovk0 , 7 лет назад

Написать программу для следующих расчетов. Создать одномерный массив размерностью N (вводится с диалогового окна) состоящий из случайных целых чисел в диапазоне [-15;25]. Вывести массив на лист. Найти минимальное число массива. Если минимум является четным, то в ячейку B1 вывести половину его значения, иначе вывести в ячейку B2 удвоенное значение.


mirageKZ: половину его значения - это половину значения B1 или минимума матрицы?
mirageKZ: пусть будет половину значения B1

Ответы на вопрос

Ответил mirageKZ
0

Задание

Написать программу для следующих расчетов. Создать одномерный массив размерностью N (вводится с диалогового окна) состоящий из случайных целых чисел в диапазоне [-15;25]. Вывести массив на лист. Найти минимальное число массива. Если минимум является четным, то в ячейку B1 вывести половину его значения, иначе вывести в ячейку B2 удвоенное значение.

Ответ:

Python

from random import randint

n=int(input('Ведите n:'))

b=[randint(-15,25) for i in range(n)]

print(b)

m=min(b)

print('min =',m)

if m%2==0:

   b[0]=b[0]//2

else:

   b[1]=b[1]*2

print(b)

Приложения:
Новые вопросы