Написать программу для решения задачи: Найти все трехзначные симметричные натуральные числа из промежутка от А до В (А и В вводятся с клавиатуры)
Ответы на вопрос
Ответил 1Elizabeth0
0
Ответ:
var
i, a, b, n, n2, j: longint;
s: string;
flag: boolean;
begin
Write('Введите через пробел границы диапазона: ');
Readln(a, b);
if b < a then begin n := a; a := b; b := n end;
if a < 11 then a := 11;
for i := a to b do
begin
Str(i, s);
n := Length(s); n2 := n div 2; flag := true; j := 1;
repeat
flag := (s[j] = s[n - j + 1]);
j := j + 1
until (not flag) or (j > n2);
if flag then Write(i, ' ')
end;
end.
Тестовое решение:
Введите через пробел границы диапазона: 800 1500
808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999
Объяснение:
eduardgofman567:
не работает
Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
Алгебра,
7 лет назад
Литература,
7 лет назад
Математика,
8 лет назад