Написать программу для расчёта суммы чисел, введённых пользователем. При этом пользователь вводит произвольное количество чисел, а для выхода из программы вводит ноль.
Приложения:

Ответы на вопрос
Ответил gregoryshanin
2
#include <iostream>
using namespace std;
int main(){
int x, summa;
bool isZero = false;
cin >> x;
summa += x;
if(x == 0){
return 1;
}
else{
while (!isZero){
cin >> x;
if (x == 0){
isZero = true;
}
else{
summa += x;
}
}
cout << summa;
}
return 0;
}
garik457:
спасибо
Новые вопросы