Информатика, вопрос задал Демитилпентан , 10 лет назад

Написать программу для Паскаля. Даны координаты вершин треугольника АВС. Найти его площадь.

Ответы на вопрос

Ответил nelle987
0

program Triangle;

 

var X1,X2,X3,Y1,Y2,Y3: real;

   p, a, b, c: real;

 

begin

   Writeln('Введите координаты точек (X1,Y1), (X2,Y2), (X3,Y3):');

   ReadLn(X1, Y1, X2, Y2, X3, Y3);

   a: = Dlina(X1-X2,Y1-Y2);

   b := Dlina(X1-X3,Y1-Y3);

   c := Dlina(X2-X3,Y2-Y3);

   p := (a+b+c)/2;

   WriteLn('Площадь равна ', sqrt(p*(p-a)*(p-b)*(p-c)));

end;

 

fucntion Dlina(var x,y:real):real;

begin

  Dlina := sqrt(x*x+y*y);

end.

Ответил Аноним
0

var
a:real;
b:real;
c:real;
x1,x2,x3:integer;
y1,y2,y3:integer;
p:real;
s:real;
begin
writeln('первые координаты треугольника x ');
readln(x1);
writeln('вторые координаты треугольгика x ');
readln(x2);
writeln('третьи координаты треугольгика x ');
readln(x3);
writeln('четвертые координаты треугольгика y ');
readln(y1);
writeln('пятые координаты треугольгика y ');
readln(y2);
writeln('шестые координаты треугольгика y ');
readln(y3);
a:=sqrt(x2-x1)+ (y2-y1);
b:=sqrt(x3-x2)+(y3-y2);
c:=sqrt(x3-x1)+(y3-y1);
p:=a+b+c;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Периметр = ',p:2:0);
writeln('Площадь=',s:1:2);
readln;
end.

Новые вопросы