Информатика, вопрос задал sashabasov93 , 10 лет назад

Написать программу для паскаля. Дана квадратная матрица
порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Ответы на вопрос

Ответил Sky09
0
uses crt;
const N=2;
var a:array [1..N,1..N] of real;
    i,j,k:integer;
begin
     k:=0; writeln('Введите матрицу:');
     for i:=1 to N do
         for j:=1 to N do
         begin
              read(a[i,j]);
              if a[i,j]<0 then inc(k);
         end;
     if k>0 then writeln('В матрице отрицательный элемент')
     else
         for i:=1 to N do
         begin
             for j:=1 to N do
             write(a[j,i]:3:0);
             writeln;
         end;
end.      
Новые вопросы