Информатика, вопрос задал MaryRich , 8 лет назад

Написать программу для паскаль! Срочно, помогите, пожалуйста!
Дано натуральное число. Установить, является ли последовательность его цифр, при просмотре их слева направо, упорядоченной по убыванию.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin;
  var s:=ReadInteger('n=').ToString;
  If s.Length<>(s.Distinct.Count) then Writeln('не является')
  else
    if s=s.ToCharArray.SortedDescending.JoinIntoString('')
    then Writeln('является') else Writeln('не является')
end.

Примеры
n= 9875431
является

n= 9753321
не является

n= 9763421
не является

Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.






Новые вопросы