Информатика, вопрос задал IstNeoN , 9 лет назад

написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода является 0.Изменить знак отрицательных чисел на противоположный.Результаты вывести на экран.

Ответы на вопрос

Ответил Vladiener
0
Предложу решение, основанное на том, что понял из текста) 

var a: integer;
begin
writeln('Вводите числа');
 a:=1;
while a<>0 do begin
readln(a);
if a<0 then writeln('Противоположное число ',abs(a));
end;
readln
end.

Можно их в массив записывать, если нужно вывести красиво.
Ответил archery
0
var n: integer;
    s: string;
begin
    writeln('Вводите числа');
    repeat
        readln(n);
        s:= s + IntToStr(abs(n)) + ' '
    until n = 0;

    writeln(s);
end.

Новые вопросы