Написать программу для pascal.
Программа считывает с клавиатуры массив из N элементов(N <1000) и выводит максимальный и минимальный элемент массива и их среднее арифметическое
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите элементы массива'+NewLine,ReadInteger('n='));
Writeln('Max=',a.Max,', min=',a.Min,', среднее=',(a.Min+a.Max)/2)
end.
Пример
n= 8
Вводите элементы массива
3.45 -2.7 1.18 0 -2 4.623 -2.734 7
Max=7, min=-2.734, среднее=2.133
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите элементы массива'+NewLine,ReadInteger('n='));
Writeln('Max=',a.Max,', min=',a.Min,', среднее=',(a.Min+a.Max)/2)
end.
Пример
n= 8
Вводите элементы массива
3.45 -2.7 1.18 0 -2 4.623 -2.734 7
Max=7, min=-2.734, среднее=2.133
Ответил petyaGavrikov
0
1.
var x : array[1..1000] of integer;
n,i,max,min : integer;
begin
write('n = ');
readln(n);
writeln('Исходный массив:');
for i:=1 to n do begin
write('x[',i,']=');
readln(x[i]);
end;
writeln;
max:=x[1]; min:=x[1];
for i:=2 to n do
begin
if x[i] > max then max:=x[i];
if x[i] < min then min:=x[i];
end;
writeln('max=',max,' min=',min);
writeln('Среднее = ',(max+min)/2:5:2);
end.
Пример:
n = 5
Исходный массив:
x[1]=12
x[2]=45
x[3]=60
x[4]=72
x[5]=68
max=72 min=12
Среднее = 42.00
-----
2.
begin
var n:=ReadInteger('n = ');
var a:=ReadArrInteger('Вводите массив:',n);
Writeln('Max = ',a.Max);
Writeln('Min = ',a.Min);
Writeln('Среднее = ',(a.Max+a.Min)/2);
end.
var x : array[1..1000] of integer;
n,i,max,min : integer;
begin
write('n = ');
readln(n);
writeln('Исходный массив:');
for i:=1 to n do begin
write('x[',i,']=');
readln(x[i]);
end;
writeln;
max:=x[1]; min:=x[1];
for i:=2 to n do
begin
if x[i] > max then max:=x[i];
if x[i] < min then min:=x[i];
end;
writeln('max=',max,' min=',min);
writeln('Среднее = ',(max+min)/2:5:2);
end.
Пример:
n = 5
Исходный массив:
x[1]=12
x[2]=45
x[3]=60
x[4]=72
x[5]=68
max=72 min=12
Среднее = 42.00
-----
2.
begin
var n:=ReadInteger('n = ');
var a:=ReadArrInteger('Вводите массив:',n);
Writeln('Max = ',a.Max);
Writeln('Min = ',a.Min);
Writeln('Среднее = ',(a.Max+a.Min)/2);
end.
Новые вопросы