Написать программу для Pascal.
Найти произведение цифр в натуральном числе.
Ответы на вопрос
Ответил Trubochist1k
0
Ответ:
program ПроизведениеЦифр;
var
число, произведение, цифра: Integer;
begin
произведение := 1;
Write('Введите натуральное число: ');
ReadLn(число);
while число > 0 do
begin
цифра := число mod 10;
произведение := произведение * цифра;
число := число div 10;
end;
WriteLn('Произведение цифр: ', произведение);
end.
Объяснение:
Ответил pb1036
0
## uses School;
var n := ReadInteger('Введи натуральное число:');
Print('Произведение его цифр равно:', n.Digits.Product)
Приложения:

Новые вопросы
История,
1 год назад
История,
1 год назад
Математика,
1 год назад
Окружающий мир,
6 лет назад
Математика,
6 лет назад