Написать программу для отыскания
max(min(a,b), min(c,d)), не
используя сложные логические условия и вложенные ветвления. Числа a,b,c,d
- целые. Протестировать программу для следующих исходных данных:
а) a=4 b=5 c=6 d=9
б) a=2 b=1 c=6 d=9
в) a=2 b=1 c=8 d=4
г) a=12 b=1 c=6 d=9
Ответы на вопрос
Ответил Аноним
0
var a,b,c,d,m1,m2,max:integer;
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
if a<b then m1:=a else m1:=b;
if c<d then m2:=c else m2:=d;
if m1<m2 then max:=m2 else max:=m1;
writeln('MAX=',max)
end.
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
if a<b then m1:=a else m1:=b;
if c<d then m2:=c else m2:=d;
if m1<m2 then max:=m2 else max:=m1;
writeln('MAX=',max)
end.
Новые вопросы
Алгебра,
2 года назад
География,
2 года назад
Биология,
10 лет назад
Математика,
10 лет назад
Математика,
10 лет назад