Информатика, вопрос задал anadeyt2019kolia , 2 года назад

Написать программу для определения полного пути и пройденных расстояний с разной скоростью для поездов, едущих t1 ч со скоростью v1 км/ч, t2 час. со скоростью v2 км/ч и t3 час. и со скоростью v3 км/ч.
В програме Pethon C++
срочно

Ответы на вопрос

Ответил SpаmeR
1

Ответ:

С++

#include <iostream>

using namespace std;

int main()

{

   int t1, v1, S1, t2, v2, S2, t3, v3, S3;

   cout << "Введите скорость первого поезда (км/ч): ";

   cin >> v1;

   cout << "Введите время для первого поезда (ч): ";

   cin >> t1;

   S1 = v1 * t1;

   

   cout << "Введите скорость второго поезда (км/ч): ";

   cin >> v2;

   cout << "Введите время для второго поезда (ч): ";

   cin >> t2;

   S2 = v2 * t2;

   

   cout << "Введите скорость третьего поезда (км/ч): ";

   cin >> v3;

   cout << "Введите время для третьего поезда (ч): ";

   cin >> t3;

   S3 = v3 * t3;

  cout << "Первый поезд прошел расстояние " << S1 << " км." << endl;

   cout << "Второй поезд прошел расстояние " << S2 << " км." << endl;

   cout << "Третий поезд прошел расстояние " << S3 << " км." << endl;

   cout << "Полный путь составил " << S1 + S2 + S3 << " км." << endl;

   return 0;

}

Новые вопросы