написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры, на pascal
Ответы на вопрос
Ответил Impersona1
0
program ex;
var a,b,c,s,k:integer;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите первое второе');
readln(b);
writeln('Введите первое третье');
readln(c);
if a>0 then
begin k:=k+1;
s:=a;
end;
if b>0 then
begin
s:=s+b;
k:=k+1;
end;
if c>0 then
begin
k:=k+1;
s:=s+c
end;
writeln('Сумма=',s);
writeln('Количество положительных чисел=',k)
end.
var a,b,c,s,k:integer;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите первое второе');
readln(b);
writeln('Введите первое третье');
readln(c);
if a>0 then
begin k:=k+1;
s:=a;
end;
if b>0 then
begin
s:=s+b;
k:=k+1;
end;
if c>0 then
begin
k:=k+1;
s:=s+c
end;
writeln('Сумма=',s);
writeln('Количество положительных чисел=',k)
end.
Новые вопросы
Литература,
2 года назад
География,
2 года назад
Математика,
8 лет назад
Алгебра,
9 лет назад
Информатика,
9 лет назад