Написать программу для обработки двумерного массива размерностью 5*5. Для каждой строки двумерного массива Q определить номера столбцов, которые содержат отрицательные элементы. Входные данные для элементов матрицы задайте самостоятельно.
Ответы на вопрос
Ответил Nironov
0
подключив предварительно библиотеку <vector>
int x[5][5];
for(int i = 0; i < 5; i++){
for(int j = 0; i<5; j++){
x[i][j] = rand()%20 - 10;
}
}
vec<int> vec;
for(int i = 0; i < 5; i++){
for(int j =0; j < 5; j++){
if(x[i][j] < 0){
for(int f = 0; f < vec.size(); f++){
if(vec(f) == x[i][j]) break;
}
else { vec.push_back(j); }
}
}
}
}
if(vec == 0) cout << "Нет столбцов с отрицательным значением";
else{ for(int j = 0, j<vec.size(); j++){
cout << vec(j) << ' ';
}
hfgdh:
на паскале надо
Новые вопросы