Написать программу для нахождения суммы цифр, составляющих число произвольной длины.
Написать программу, позволяющую определить, сколько заданных символов в данной фразе (искомые символы и фраза вводятся с клавиатуры. Например, сколько букв А и а в слове АбракАдабрА)
Ответы на вопрос
Ответил Б0Г
0
пункт а:
Насколько я помню, в паскале невозможно реализовать бесконечный цикл, поэтому решение будет слегка притянуто за уши. Например если вы введете число из 9001 символа, программа будет работать неккоректно. Для выхода из цикла используется 'метка'.
a, counter, Summa : integer;
Label Transfer;
Begin
writeln('Введите число');
readln(a);
counter := 1;
counterTw0 := counterTwo + 1;
while counter < 9000 Do
begin
counter := counter +1;
if (a div counter) < 0 then Transfer
else counterTwo := counterTwo + 1;
else;
Goto Transfer;
//Узнали, что в числе counterTwo символов
while counter < counterTwo Do
Summa := Summa + ((a div counter) mod 10);
Summa := Summa + (a mod 10);
writeln(Summa);
end.
Насколько я помню, в паскале невозможно реализовать бесконечный цикл, поэтому решение будет слегка притянуто за уши. Например если вы введете число из 9001 символа, программа будет работать неккоректно. Для выхода из цикла используется 'метка'.
a, counter, Summa : integer;
Label Transfer;
Begin
writeln('Введите число');
readln(a);
counter := 1;
counterTw0 := counterTwo + 1;
while counter < 9000 Do
begin
counter := counter +1;
if (a div counter) < 0 then Transfer
else counterTwo := counterTwo + 1;
else;
Goto Transfer;
//Узнали, что в числе counterTwo символов
while counter < counterTwo Do
Summa := Summa + ((a div counter) mod 10);
Summa := Summa + (a mod 10);
writeln(Summa);
end.
Новые вопросы
Геометрия,
2 года назад
Английский язык,
2 года назад
Литература,
9 лет назад
Литература,
10 лет назад